Updating Manager - You are not using an encrypted connection

When I’m trying to update the packages from webtest.cern.ch/en/admin/reports/updates/update, I run into the following.

I read this post: First attempt at migrating to Drupal 9 -> many questions - #6 by joachim

But I’m not sure what I’m doing wrong.

To update modules you must follow the procedure described here:
Then if you have still problems, do not hesitate to come back and post in Drupal community.


But I’m still confused.
The third step: “3. Paste the folder with the updated content”.
Where do I get the updated content?

Hi Emil

If you rely on community contributed modules, you need to find an updated and compatible release through https://www.drupal.org/project/project_module. You can download an appropriate release, unzip it, and otherwise paste it in the correct folder to overwrite the current installation. We appreciate that this is a rather cumbersome approach to updating modules: We are keenly aware of this and are looking into ways in which we can ease this process substantially.

Please let us know if you face any problems doing the above.


I followed the instructions on updating the modules “the new way”, but got stuck at the last step, i.e. I am not able to upload the unzipped folder to the current installation. I am accessing the webdav via a browser, and drag and drop doesn’t work. Please see my screenshot:

How can I move forward with updating from here?

Kind regards,

Hi Lina

The web interface does not allow you to upload entire folders. If you are on MacOS or Windows, we recommend using and connecting through CyberDuck (on Windows specifically, you can also just use the built-in Explorer), see more information here: https://drupal-tools.web.cern.ch/access-webdav-in-openshift-macos. If you are working on Linux, have a look at Nautilus instead.

Hopefully this helps!


Hi Joachim,

Thanks for the tips. I used CyberDuck to update 4 modules (entity print, swift mailer, pdf generator and date popup). There was no window asking me to confirm the overwrite since the modules folders have different titles, I guess. Please see the screenshot.

When I go back to the website, I still see these modules requiring update (both under the Extend-update tab and under Upgrade reports). Is this normal?
The main reason of my attempt to update these modules is that the entity print module stopped working properly after the migration (the generated pdf stopped rendering the content, and remains blank).

Hi again

The reason why you are not prompted to do an overwrite is because you are moving a module (folder) with a different name; e.g. pdf_generator and pdf_generator-2.0.1. When you download and unzip the modules from https://drupal.org/, you get a folder with the machine name of that module. In the above example, that would be pdf_generator. Inside that folder would then be the code for the corresponding version, in this case 2.0.1.

As such, I suggest you go ahead and remove the new modules you have uploaded (as these are essentially new modules!), ensure you download and unzip the correct versions and then otherwise check the name of the folders match the machine name such that you can actually overwrite.

See https://drupal-tools.web.cern.ch/update-modules-webdav for more information.


oh, there were other folders inside the ones that I tried to upload! Now finally I managed to complete the update.
Thank you!

Hi again

No worries, happy to hear you got things resolved!

Please let us know if you face any other issues.


But if it’s a module that requires submodules like svg_image, I still need to follow this entire guide: Creating a drupal site with extra modules [Temporary], right?

But the guide says “Creating a drupal site with extra modules” - I don’t need to create a site. I already have the site. It’s confusing.

How are webhooks even involved here?

Hi Emil

Are you not able to install that module directly?

You should be able to do this simply by pasting the folder in the modules folder on your site.


Some of the modules requrire submodules, like svg_image.
So I have to use composer… right?