Allow website to appear on google search

I have created a website with Drupal8 for the new CERN club Eco-Actions:

I would like to know how to allow the website to appear on google search.
Note: I am a complete begginer in this space :smiley:
Thank you in advance.

Hi Vasili,

Go to and uncheck the ‘Avoid indexing’ option. Then clear caches and it should be ok. It will take some time for Google to start indexing your website though.

Thanks a lot!!
Do I need to as somewhere “keywords” so we can be found in google search?

For that you need to install the Metatag module. Go to Extend, search for Metatag and install it. Then go it its configuration page and edit the Global meta tag and add your keywords there. Save and clear caches again.

-When I installed the metatag, this update message appears:

-How do I clear the caches? :smiley:

-In the EDIT metatag page, I just need to fill in the keywords and save? nothing more?

Thanks again

Go to Configuration->Performance and Clear Caches

Yes just add the keywords and save.

Hello, still the website is not appearing in any google search.
How could I resolve the problem?

I would recommend to go to Google Search Console and add your website there and index it. In a week should be ready.

Google asks me to copy paste a text in the DNS configuration in order to verify.
Where can I find this on drupal8 interface?

There is no way to do that.

You can create a Google analytics account, enable the Google Analytics module on your website and put the ID there.

In this way you will verify your website.

Where do I eneble the Google analytics module on the website ?

Go to Extend and search for Google Analytics. Enable it and then configure it and add the Property ID that you will get from Google Analytics website once you have created a property.

I have created the google analytics account and enabled it and added the ID on drupal8.
Now, in order to do the validation via google analytics on the google search console, it proposes these steps:

I am stack at this point.

You should click VERIFY under Google Analytics. Your website now contains the tracking code.

In order for this to work you must have created the Google Analytics property with the same Google account that you registered the website in Google Search Console.

The problem was that I didnt have the correct Web property address in the form of UA-xxxxxx-yy.
To do so, I had to create an Google Analytics UNIVERSAL.

In any case, now the verification in console was successful so I will just wait to see if we will be googleable now.