CERN icon component issues

Summary

No options available / displayed to set up icon component

Steps to reproduce

Each time you add an icon component in a Landing page

Possible fixes

?

Related issues

?

Attachments

Blockquote
Notice : Undefined index: name in Drupal\field_ui\Element\FieldUiTable::reduceOrder() (line 228 of core/modules/field_ui/src/Element/FieldUiTable.php ).
Drupal\field_ui\Element\FieldUiTable::reduceOrder(Array, Array) array_reduce(Array, Array) (Line: 233) Drupal\field_ui\Element\FieldUiTable::reduceOrder(Array, Array) array_reduce(Array, Array) (Line: 108) Drupal\field_ui\Element\FieldUiTable::tablePreRender(Array) call_user_func_array(Array, Array) (Line: 100) Drupal\Core\Render\Renderer->doTrustedCallback(Array, Array, ‘Render #pre_render callbacks must be methods of a class that implements \Drupal\Core\Security\TrustedCallbackInterface or be an anonymous function. The callback was %s. Support for this callback implementation is deprecated in 8.8.0 and will be removed in Drupal 9.0.0. See https://www.drupal.org/node/2966725’, ‘silenced_deprecation’, ‘Drupal\Core\Render\Element\RenderCallbackInterface’) (Line: 781) Drupal\Core\Render\Renderer->doCallback(’#pre_render’, Array, Array) (Line: 372) Drupal\Core\Render\Renderer->doRender(Array) (Line: 444) Drupal\Core\Render\Renderer->doRender(Array, ) (Line: 200) Drupal\Core\Render\Renderer->render(Array, ) (Line: 226) Drupal\Core\Render\MainContent\HtmlRenderer->Drupal\Core\Render\MainContent{closure}() (Line: 573) Drupal\Core\Render\Renderer->executeInRenderContext(Object, Object) (Line: 227) Drupal\Core\Render\MainContent\HtmlRenderer->prepare(Array, Object, Object) (Line: 117) Drupal\Core\Render\MainContent\HtmlRenderer->renderResponse(Array, Object, Object) (Line: 90) Drupal\Core\EventSubscriber\MainContentViewSubscriber->onViewRenderArray(Object, ‘kernel.view’, Object) call_user_func(Array, Object, ‘kernel.view’, Object) (Line: 111) Drupal\Component\EventDispatcher\ContainerAwareEventDispatcher->dispatch(‘kernel.view’, Object) (Line: 156) Symfony\Component\HttpKernel\HttpKernel->handleRaw(Object, 1) (Line: 68) Symfony\Component\HttpKernel\HttpKernel->handle(Object, 1, 1) (Line: 57) Drupal\Core\StackMiddleware\Session->handle(Object, 1, 1) (Line: 47) Drupal\Core\StackMiddleware\KernelPreHandle->handle(Object, 1, 1) (Line: 106) Drupal\page_cache\StackMiddleware\PageCache->pass(Object, 1, 1) (Line: 85) Drupal\page_cache\StackMiddleware\PageCache->handle(Object, 1, 1) (Line: 47) Drupal\Core\StackMiddleware\ReverseProxyMiddleware->handle(Object, 1, 1) (Line: 52) Drupal\Core\StackMiddleware\NegotiationMiddleware->handle(Object, 1, 1) (Line: 23) Stack\StackedHttpKernel->handle(Object, 1, 1) (Line: 694) Drupal\Core\DrupalKernel->handle(Object) (Line: 19)


Hello Michel,

Can you specify the website?

Thanks

Konstantinos

https://cryo4lhc-dp8.web.cern.ch/
The error message is displayed when you go to

  1. Home
  2. Administration
  3. Structure
  4. Paragraphs types
  5. Cern icon component
  6. Manage form display

Hello Michel,

I applied a fix to your website. The issue was on the grouping of the fields thats why you could not see it in the editing of landing pages.

Let me know if you see the error again.

Konstantinos

Thanks Konstantinos,
Yes it works.
Did I do something wrong to have this issue ?

No you did not. It is a configuration issue that the Easy Start template had so you got it from there.

Good that you mentioned it because I fixed it in the template too :+1:

Konstantinos

OK, good news.
Michel