How to have my Indico Events considered both as "French" and "English"?

Hi everyone,

On my website I have 2 types of events appearing as agenda boxes in the same grids (e.g. :

  • Indico events from the feed - each node is in 1 language
  • Events (i.e. events not related to an Indico event, e.g. not organized by CERN but where we participate) - each node exists both in English and French

As I am translating my website I have a problem with my view since:

  • If I don’t filter by translation language (= interface language selected for the page), my “Events” appear twice, in French and English whatever the selected language is.
  • If I do filter by translation language, my Indico Events won’t appear in the French version.

Any idea how to fix this ?

Many thanks,


Hi Marie,

First go to Content->Feeds and delete all the imported events from Indico.

Then go to Structure->Content type amd Edit the Indico Event content type.

Go to Language settings and select Default language -> Not specified or not applicable

Save and clear caches.

Go to Content->Feeds and import events from Indico.

Then go to your view and add the filter Content: Translation language and select the values Interface text language selected for page and Not specified or Not applicable depending on what you have selected before.

Now your view should display events properly whenever you switch to English or French without appearing twice.

Thank you very much!

@sboutas,there is one more little problem here.
When I click on a “French” Agenda Box, it redirects me to the “English” version of the Indico event node.
There is the same problem on


Hi Marie,

This is normal because the Indico events don’t have a language set and their links follow the pattern of the English links.

It would be possible to fix this if the view had fields instead of using a display format but you wouldn’t get the nice layout of the Agenda box.

Another way to fix this is to create a second Indico feed and mark it as French by setting the language manually in the imported nodes but that means that you import the same event twice in the system creating additional nodes and I wouldn’t advise that.

Dear Sotirios,

Thanks for your explanation.
The possibility to have a direct link to the Indico event from the Agenda box would definitely be the best solution then!

Kind regards,


Hi Marie,

This requires a new field in Indico content type and a new mapping in the feed so Title and Indico link can be combined.

I took a backup and I have made the changes on your website. Now the title points to the Indico page.

Dear Sotirios,
Thank you very much for the change.
Will it also work on my collision display of events? I cannot know right now because we don’t have any future Indico event.

Yes it should work for collision display as well.

Dear @sboutas ,
The solution is not working anymore…
If I only select “Interface text language selected for page” and “Not specified”, my Indico Event won’t be displayed… It was working before, but not anymore… Should I re-delete and re-import my Indico Events?
Thanks for your help,

Hi Marie,

That’s normal since the Indico events don’t have a language set.

What kind of solution was working before? Can you elaborate?

The one you shared upper:

You had the Indico events imported as French language. I switched it to Non specified now, deleted the events and import them again.

The thing is that you don’t have any Event in English and French to test it but in theory it should work.

When you are in French your Events will be displayed in French and the all the Indico Events. When you are in English it should display your Events in English and all the Indico Events.

Thanks a lot!!