Indico Feeds - D8 not mapping?

Hi - I’m trying to set up the usual indico feed to show as an Upcoming Events block on the homepage.

However the Fetcher consistently fails to find events in Indico, as apparently the mappings aren’t correct. I’ve checked the mappings - it’s the default which I haven’t touched, and they look OK. Screenshot attached…

I have set up Indico feeds exactly as was on the D7 site - following set Indico Fetcher>Indico event, included my Indico API, set up the content feed… etc.

And yet it claims the mappings are wrong, but I can’t see how else the mappings would be.

Thanks in advance for help…



Mappings screenshot:


Hi Cath,

according to what I can see on the errors, it seems that Drupal somehow is getting NULL values for these fields…

I am wondering whether there might be something wrong with these events that have empty or NULL values…

Did you try changing the category of this importer so it will import different Indico Events? Maybe it can be due to a permissions problem that makes the events ‘visible’ but the information inside not visible for your API key?

Just some guesses, but maybe worth checking out!



Hi Cath,

That’s strange. Did you make any changes in the mappings section of the feed?

This should work out of the box.


That’s the problem… it didn’t work out of the box, and I definitely haven’t made any changes to the mapping. I’ve tried it with both API keys, just the public key… compared the feed configuration related set-ups to what I have in D7 for the same site (, and it’s just not working in D8. It works absolutely fine in D7 though.

I just migrated the site over to D8 and realised that the Indico Feed wasn’t working. After a bit of clicking and trying to create new feeds, I decided to uninstall and reinstall to start over again, but still the same problem. It just does not want to pick up any fields from Indico - I’m getting the same error message every time - NULL values.

Any tips very welcome, I’m completely stuck…


Do you mind if I uninstall the Indico module and install it again. I need to delete all the feeds that you created as well in

Is that ok?

Hi Cath,

It’s fixed. I just uninstalled everything and I installed the module again. There was some bad feed configuration on the website.


Thanks Sotirios - we took this conversation offline (er… to Mattermost if that counts as ‘offline’), but just for reference for anyone else here who might have the same issue:

it looks like something weird broke when I migrated the site from D7 to D8. So uninstalling the Indico Feeds module, deleting everything related to any created feeds, then re-installing, reconfiguring etc etc seems to do the job.

1 Like