Problem with the French version of a content type


Since last week, when we want to update a page (content type “offer” on in French, the following message appears: “Items in non-translatable fields can only be finalized by updating the original language.”
It makes no sense since fields that apply to all languages are hidden. We are not trying to update those ones, and anyway we can’t…

Steps to reproduce

E.g. go to Masterclasses internationales | Le CERN et ses voisins and try to modify ANY field.
The following messages will appear:

Possible fixes

No idea

Hmmmm that’s weird. Maybe because some of the hidden fields are mandatory?

Try to display all the fields or not make mandatory the hidden ones and try again.

But I really want the fields that apply to all languages to be hidden in the French form, and I want some of them to be mandatory. It has been working this way from the past 7 months…

If it used to work and now it doesn’t then you need to remember if you changed anything lately in your website. If not then open a ticket to Drupal infrastructure so admins can have a look.

No, we haven’t edited the content type in months. I will open a ticket, thanks!

Ok by unchecking the option Hide non-translatable fields in fixes the issue. I suggest you don’t hide the non-translatable fields.

I think it is related to this issue

There is no official fix yet and the community proposes to write a custom module that bypasses the validation.

Hi Sotirios,

Thanks for checking.
I don’t think it is related to the issue you mention since the problem only appeared last week.

It’s a pity that we can’t hide untranslatable fields, because that means that any small change has to be done twice…

Shouldn’t it be related to the last updates of the template?

Ok I think this is the issue

It was reported in January and there is a patch.

Please open a ticket to Drupal infrastructure pointing to that issue and ask the to apply the patch. It’s a bug in the core. Check the steps to reproduce that describe the error.