Theme colors and CERN Full HTML Text format missing

I am trying to update my Drupal 8 site but as you see at , the colour of the site name and the tag texts are not in white. I checked the appearance -> CERN theme settings and the color associated to the header text is correct.

I am also missing the “CERN Full HTML” editing option in the CKEditor (only FUll, Basic, Restricted are proposed) of this site.

Could you please let me know if this can be fixed easily ?

I see that this style is probably managed by Body: Link ones, could anybody confirm?

For the CERN Full HTML, the module is enabled but the text format doesn’t appear on /admin/config/content/formats

Hello @eduardoa,

Can you give me access to check the settings?


Hey @eduardoa

Let me know if something is not clear.

Hello @kplatis
Thanks for your advices.

  • Regarding the site name, I have disabled ‘site branding’ block of test-volmeur2 as suggested. The logo still appears but the site name completely disappears. On another site created more recently (test-digital-memory), these problems do not exist at all…
  • Regarding Full HTML CERN, I will try your suggestion later. Many thanks.


Hello @jeanyves,

Regarding the issue with the site name. I took the initiative to clone your site and apply some tests on the clone site because the issue seemed weird. For some reason the theme settings were bugged and weren’t changing.

The only feasible way I found to fix the bugged settings was to uninstall and re-install the theme.

More analytically:

  1. Change to another theme (ex Bartik, Seven etc)
  2. Uninstall the CERN theme
  3. Install and set as default the CERN theme

You will notice that the settings are a bit messed up so to go back to the initial form of your site:

  1. Disable the Site Branding and User Account Menu blocks
  2. Check the “Show Site Name” settings and upload your logo in the CERN theme settings

I also noticed that you had applied some changes in the bootstrap theme. In general try to avoid it and apply the settings on the CERN theme.


Hello Kostas, @kplatis
Many thanks, I have run your recipe and the site name and logo appears well now. That’s great.

What I still find different from the new site I created recently is:

  • The color of the taxonomy terms in the ‘collection’ view
  • When adding a new basic page, in CKEditor, the “Full HTML” option can be selected, but there is no “Full CERN HTML” that allows the inclusion of CDS images/videos.

Many thanks for your help,

Hello all,

I am facing the same problem with the CERN Full HTML text format.
There are many buttons missing from toolbar configuration, such as the CERN font or the letter size.

Could you please help us with that?

Thank you!
Kind regards,

Hey Evi,

Is the CERN Full HTML Format module enabled? If not, then please enable it and see if it fixes your issue. If yes, then post the URL of your website in order to have a closer look.



Hello Kosta,

Yes, everything is enabled. I do not know why it is not working.
Here is the link:

Thank you!!

Hi Evi,

I have noticed that CERN Full HTML text format was misconfigured so I took the liberty to apply the correct settings. It should be ok now.

Also, I switched the order of the text formats in page so CERN Full HTMLwill always be the default one. When you create or edit a node you can select the text format that you want to use from the Text Format drop down menu under the Body field.

Hello Sotiri!

Thank you for you help!
Yes, now it works perfect now! Thank you!

Kind regards,