Unable to enable CERN modules due to dependencies

Hey all (probably more specifically @joachim ),

I have a fresh site, D9, newly created, but seem to be missing dependencies for the CERN theme modules.

For example, I just tried to enable CERN Landing Page only (after several timeout issues trying to enable more), but then got the following error:

All associated modules have auto-enabled, except CERN Section due to missing dependencies, and consequently still no CERN Landing Page.

Help please! :pleading_face:
-cath

PS. Please DM me on mattermost for the website URL, it’s not one I want to be public for the time being.

Hi Cath

Thanks for reporting this! We are chasing a lead on this particular issue affecting you and a handful of other websites. As soon as we have confirmed what we believe to be the root cause, we will get a patch pushed accordingly. We are working diligently to get this resolved ASAP.

We appreciate your patience!

Thanks!

Hey @joachim

I am still having the same problem, except for a new (different) website which I need to get out pretty quickly (https://wlcg-test-cern.web.cern.ch/)

How’s the progress going on this issue?

Thanks,
Cath

Hi Cath

The issue with the CERN Landing Page only applies to websites moved directly from the old infrastructure (or new websites cloned from such websites) and is caused by database misconfiguration. If you create a new website today on the new infrastructure, the CERN Landing Page will not be throwing this error.

Attempting to access https://wlcg-test-cern.web.cern.ch/, I am prompted to complete the Drupal installation…? If you do encounter the Landing Page error, you can connect to your pod (see https://drupal-tools.web.cern.ch/work-with-openshift-cli for how to do this), and run the command

drush config-set core.base_field_override.node.landing_page.uid default_value_callback 'Drupal\node\Entity\Node::getDefaultEntityOwner'

followed by a

drush cr

Thanks!

Hi @joachim

Er… it seems I need a Red Hat account and subscription to download the OpenShift console (I am following this procedure as I don’t have the console installed, it appears).

Is this something CERN already has - are there organisational credentials I can already use?

thanks for any tips…
-cath

Hi Cath

Please proceed from here directly: https://drupal.cern.ch/command-line-tools

I have updated the guide accordingly.

Sorry for the confusion!

@joachim the drush command you mention above doesn’t seem to work on WLCG right now. Is it due to Drupal 9.3? Here’s what happens when I try running it:

/app $ drush config-set core.base_field_override.node.landing_page.uid default_value_callback 
'Drupal\node\Entity\Node::getDefaultEntityOwner'
 [error]  Config core.base_field_override.node.landing_page.uid does not exist 

In fact, there’s no configuration core.base_field_override.node.landing_page. There are other core.base_field_override.node.* settings.

Thanks for flagging…!

Something has clearly changed since November when I wrote the above instructions as those were indeed what we used to resolve the same issue on different websites. I will have to look into this and get back to you both. As you have already submitted a ticket on the matter, @noble, I will respond on the ticket and here in case others face the same issue.