Webform submit button

Dear Drupal team,

I’ve got an issue with the following submission form: Submit a WQD event | WQD. It works fine for me and a lot of other users, but still, there are a couple of people reporting that they are unable to click on the “submit” button even if all the fields are filled in. Might you know where the issue lies?

Thank you very much in advance!

With best regards,

Just a guess, if you go to the webform, what do you have on the ‘access’ tab for the “Submit Button” when you edit it ? You can have a look at the People to see if there are differences in roles between those who can do it and those that can’t.

Thank you very much for your quick reply, Tim! On the access tab, both boxes (Anonymous &
Authenticated user) are checked. The weird thing is that for some external users it works and for some not. Maybe a silly guess, but could it depend on a browser?

Hello Anastasiia,

It can be the case that some users had already submitted one time their form but they want to re-submit it. I think by default this is not allowed. If this is the case but you want to change it you can go to:
Webform → Setting → Submissions
and click or unclick relevant fields according to your preference.
For example you can click:
Allow users to duplicate previous submissions? or Allow users to update a submission using a secure token?

Kind regards,

1 Like

You can check if the people that complained have already submitted their form in:
If you see their names there I think this is the problem.

Most Importantly, navigate to:
In Form Behavior uncheck Prevent duplicate submissions?.
If this is clicked the submission button is de-activated.
Be careful when you receive the results and consider duplicates.

Hello Apostolos,

Thank you very much for your reply! I have indeed prevented duplicate submissions, but have done so on purpose thinking initially that it might be better in terms of security, but also in terms of avoiding any input being submitted twice by mistake. However, it might be actually useful to have the option enabled as it might be that the events submitted are the same, but only take place in different cities. Thank you for giving me this idea!

As to the submitters, these are all people who use the form for the first time :frowning: so I am really puzzled why the input cannot be submitted.

…And I have just read the rest of the messages. Thank you! I will uncheck the Prevent duplicate submissions straight away and keep fingers crossed that it helps!

Ok you can put this option back to how it was.

I tried to complete it but I have a problem as well. Let’s try two things:

  1. Remove the Captcha as it may creates issues.
  2. Check who can create submission by navigating at: Webform → Setting → Access. Maybe click the first option: Utilisateur anonyme.

Thank you Apostolos! Have done accordingly for the Captcha, but for the second point, I don’t see the option “Utilisateur anyone”. This is what I can see:


I received your submission, Apostolos!

ok there is a problem when the user choose as a selection in the VENUE the In person event. When I choose that I cannot submit. I see that when you choose this option the address field is created. Can you check if there is a conflict there?

Many many thanks, Apostolos, and also for the Zoom call just now! The issue was in the conditions. You really helped a lot!

1 Like