Cannot add image in CERN Full HTML long text fields (CKEditor)


I must miss something obvious… but after some days of trials, I open this post looking for help.

I have a new content type with many long formatted text with CERN Full HTML as the only possible format.

I cannot add any image (from my file system) in these texts.
Whenever I click the image icon on CKEditor, I get a “Loading…” text but no dialog box opens.

I have checked the parameters in Configure > Text formats and Editors > CERN Full HTML > Configure.

Under the Image tab, all options seem correct:

  • Enable Image Uploads (checked)
  • File storage: Public local files served by the webserver
  • Upload directory: inline-images (I have created it manually)
  • Maximum file size: 5 MB
  • Maximum dimension: 1920x1080

Site:, content type Visit Point, fields: all with CERN Full HTML format.

Any help is more than welcome.


Hello Francois,

To be honest this “Loading…” issue sounds like cache/browser. I will have a look and let you know.


Francois can you try again?

Can also be a proxy issue while teleworking?

I found that it is related to this issue here

I have disabled the image field, saved and then re-enabled it again and it worked.

I don’t understand why an image field would affect CKEditor’s add image functionality and also I am not sure why this issue appeared only in this website.

1 Like

Works! Thanks! Seems a quite boring bug to me…
But good to know how to fix it.