Test website and error message “Application is not available”

https://alice-offline.webtest.cern.ch/ shows the following message “Application is not available”.
Can you have a look?
Thanks and best regards,

Hi Guillermo

Thanks for reaching out, I am flagging this accordingly.

Your site will become available ASAP.

We appreciate your patience!

Dear Drupal team, we have unfortunately the same issue with the https://quantum-dev.webtest.cern.ch/
We would be very grateful for your help!

Hello, same problem here: https://atlas-collaboration-nominations.webtest.cern.ch

Hi Anastasiia and Lina

Thanks for raising this as well.

I have noted your websites too and we will get them resolved ASAP.

We appreciate your continued patience!

Many thanks Joachim!
May I also please ask you to add https://survey-poll.webtest.cern.ch/ to the list of the trouble-making websites. It has a slightly different problem. Please see my screenshot:

Hi again

Just following up:




are now both available.

@gmesaper: Your website appears to have some issues with the Indico plugin and thus remain inaccessible as of this writing. We have not encountered this problem before and thus require additional time to investigate the matter. Thanks for your continued patience!

@ldannesb: Thanks for flagging the survey-poll website! We will be having a look and get back to you as soon as possible.

We appreciate your continued patience.


Dear Joachim

Indico plugin error was solved, I re-define the php function cal_days_in_month() because is absent in the new php environment. But we have the following error after the login attempt

The website encountered an unexpected error. Please try again later.

Symfony\Component\DependencyInjection\Exception\ServiceNotFoundException : You have requested a non-existent service “simplesamlphp_auth.manager”. in Drupal\Component\DependencyInjection\Container->get() (line 153 of core/lib/Drupal/Component/DependencyInjection/Container.php ).

Can you take a look?

best regards

Same problem for https://visits.webtest.cern.ch/. All my other website are accessible on webtest.cern.ch.

Best regards,


Hi Guillermo!

Glad to hear you got the Indico issue resolved. I note in the error message that this concerns the SimpleSAMLphp module. Is this one you actively use? As part of the move to OpenShift, we are also taking the opportunity to strengthen general security. This means that we have phased out SimpleSAMLphp in favour of OpenID Connect (https://www.drupal.org/project/openid_connect). Generally this should all happen behind the scenes, so the fact that you are seeing this suggests you might have it as a dependency or maybe as part of a custom module? If you do use it, could you please share details on how specifically?


Hi François

Thanks for raising this!

Unfortunately the visits.webtests.cern.ch is among a group of just four websites encountering a Drupal Core issue concerning the ModuleDependencyMessageTrait. We are actively working on this issue, though given the nature of the error, it is unfortunately going to require some time. We apologise for any inconveniences this may cause and very much appreciate your continued patience.

I will reach out via e-mail directly once we have news to share.


Dear Joachim

Yes, we use “simplesamlphp” service as part of our custom user module (ALICE people). for example

   public function alice_people_user_check_egroup( $group ) 
      if( empty($group) ) return false;

      $service = \Drupal::service('simplesamlphp_auth.manager');
      $e_groups = $service->getAttributes()['egroups'];
      if( !isset($e_groups) )  return false;
      // some old pwg have disappear, we ned to give the rights to somebody else
      if( $group == 'alice-convenor-pwg1' )
         $group = 'alice-convenor-pp';

      return in_array($group, $e_groups);   

best regards


Similar issue with my website cas.webtest.cern.ch.
“The website encountered an unexpected error. Please try again later.
TypeError: Argument 1 passed to Drupal\Core\Extension\ThemeHandler::addTheme() must be an instance of Drupal\Core\Extension\Extension, null given, called in /app/web/core/includes/theme.maintenance.inc on line 73 in Drupal\Core\Extension\ThemeHandler->addTheme() (line 118 of core/lib/Drupal/Core/Extension/ThemeHandler.php).”

Thanks in advance,

Good morning,

the website https://db-blog.webtest.cern.ch does not work either “The website encountered an unexpected error. Please try again later.”.

Could you check,
thank you,

Hi, I have met the same problem when I was trying to update some modules.
After a failure, it now shows “application is not available” message.

Could you help to check,
thank you,

Hi Anastasiya and Eric!

Thanks for raising this.

I have flagged both of your websites accordingly and we will re-run the preview creation.

We appreciate your continued patience!


Hi Jiahui

Thanks for raising this. Your issue is a bit different than the others: Are you please able to detail which module(s) you attempted to update causing this error to be thrown? I have flagged your website accordingly, though I cannot promise that changes you have attempted to make persist.



Thank you for the reply. I was trying to update the modules listed below:

After downloading the updates I first met the problem as mentioned in (asking for connection details)

and then got the “Application is not available” message when I tried to access the test site again.


The preview website cas.webtest.cern.ch still ‘encounters an unexpected error’ and there is no possibility to prepare for the upgrade.
Does this mean that after the 2nd of November the upgraded site will encounter an error As well and will not open?
Thanks in advance for any assistance.